You are viewing as a Guest.

Welcome to skatingforums - over 10 years of figure skating discussions for skaters, coaches, judges and parents!

Please register to be able to access all features of this message board.

Author Topic: Blade mounting issue  (Read 339 times)

0 Members and 1 Guest are viewing this topic.

Offline roseyhebert

  • Pairs Partner
  • **
  • Joined: Jul 2011
  • Posts: 211
  • Total GOE: 6
Blade mounting issue
« on: September 09, 2011, 10:02:58 AM »
I have mounted my new blades and used the same spot as my old ones because that was a perfect location for the blade.  But my concern is that the new blades do not sit perfectly flush against the sole.  It's like the toe plate is too long for the boot.  The heel plate won't sit flush against the sole either.  The old screw holes are perfectly flush with the sole leather and can't feel where they used to be.  When I screw the new blades down as far as they will go, the heel plate doesn't sit flush with the heel of the sole.  I read that this can cause the blade to warp/twist.  The heel plate is about a millimeter off the sole in one spot.  What should I do?

Offline Qarol

  • Diamond Blocking
  • **
  • Joined: Aug 2011
  • Location: Rock Hill, SC
  • Posts: 116
  • Total GOE: 9
  • Gender: Female
    • edges and footwork
Re: Blade mounting issue
« Reply #1 on: September 09, 2011, 10:09:39 AM »
Yikes. I wouldn't have a clue. Do you have a pro shop with someone who knows what they're doing to take your skates to and ask?
If you're not falling, you're not working hard enough...

http://hydroblading.blogspot.com/

Offline roseyhebert

  • Pairs Partner
  • **
  • Joined: Jul 2011
  • Posts: 211
  • Total GOE: 6
Re: Blade mounting issue
« Reply #2 on: September 09, 2011, 10:12:22 AM »
Yikes. I wouldn't have a clue. Do you have a pro shop with someone who knows what they're doing to take your skates to and ask?

Sadly, no.  The person that mounted my blades is no longer at the rink and I don't know anyone else to take them to.